Last Access

New ideas and constructive comments go here.

Moderator: Moderators

Post Reply
Black20VT
Posts: 134
Joined: Sat Nov 05, 2005 12:35 pm
Location: UK
Contact:

Last Access

Post by Black20VT » Sat Sep 06, 2008 4:18 am

Hi,

Just another quick feature request;

Would be nice to see when users last accessed their mail, be it POP or IMAP.

Thanks,

Chris.

RollerNetSupport
Site Admin
Posts: 850
Joined: Wed Nov 17, 2004 10:05 pm
Location: Nevada
Contact:

Post by RollerNetSupport » Sat Sep 06, 2008 11:59 am

This one might be a bit difficult, but we'll give it a shot. Created new feature ticket #197: IMAP/POP3 Last Access
Technical Support support@rollernet.us
Roller Network LLC

Black20VT
Posts: 134
Joined: Sat Nov 05, 2005 12:35 pm
Location: UK
Contact:

Post by Black20VT » Sun Sep 07, 2008 12:22 pm

Ok great, thanks for acknowledging and adding.

Just out of interest, is the 'feature list' publicly available to view, or for internal use only?

Thanks again,

Chris.

RollerNetSupport
Site Admin
Posts: 850
Joined: Wed Nov 17, 2004 10:05 pm
Location: Nevada
Contact:

Post by RollerNetSupport » Sun Sep 07, 2008 9:25 pm

The tickets are currently internal only. Although if you know a ticket number, you can ask about its status.
Technical Support support@rollernet.us
Roller Network LLC

RollerNetSupport
Site Admin
Posts: 850
Joined: Wed Nov 17, 2004 10:05 pm
Location: Nevada
Contact:

Post by RollerNetSupport » Wed Jul 15, 2009 10:28 pm

This request has been completed. Sorry for the delay!

We added a new stats page for mail boxes:
https://acc-dev.rollernet.us/mail/box.php?stats
Technical Support support@rollernet.us
Roller Network LLC

Black20VT
Posts: 134
Joined: Sat Nov 05, 2005 12:35 pm
Location: UK
Contact:

Post by Black20VT » Thu Jul 16, 2009 2:20 am

RollerNetSupport wrote:This request has been completed. Sorry for the delay!
Superb! Just stumbled across this whilst checking something within the account before reading this post.

This is just the job! Thanks for implementing, will be very useful.

:D

Black20VT
Posts: 134
Joined: Sat Nov 05, 2005 12:35 pm
Location: UK
Contact:

Post by Black20VT » Fri Jul 17, 2009 3:23 am

Hi,

I've just been looking at the logs again this morning and I'm not 100% sure it's correct.

For example, I've had emails from a couple of users this morning who are on the logs, accessing via IMAP, however, both of them are showing as last access yesterday morning?

How often does it update and does it log all access protocols?

With regards to IMAP, how does it log IMAP connections, just the initial connection as it's held open on IDLE?

Just to add, I've just checked outbound mail logs and other users have been online and sending mail today, but access still shows as yesterday?

Thanks.

RollerNetSupport
Site Admin
Posts: 850
Joined: Wed Nov 17, 2004 10:05 pm
Location: Nevada
Contact:

Post by RollerNetSupport » Fri Jul 17, 2009 9:03 am

It updates continuously, however it's only recording logins. If someone leaves their mail client open for two days and it holds the connection the whole time, that's only a single login event. There is no logging for IDLE. Likewise sending mail won't trigger an IMAP/POP3 login event unless the client disconnects and reconnects at the same time.
Technical Support support@rollernet.us
Roller Network LLC

Black20VT
Posts: 134
Joined: Sat Nov 05, 2005 12:35 pm
Location: UK
Contact:

Post by Black20VT » Fri Jul 17, 2009 9:19 am

Hmm, I can't quite work this out then.

I've just checked the logs again and it still shows logins for yesterday only on all account. I've logged into one of the accounts by webmail today multiple times and that doesn't show. Also, that account has been accessed via IMAP multiple times today and the PC has been off between times and they're not showing either?

Am I doing something wrong? Is there anything you'd like me to try/test?

RollerNetSupport
Site Admin
Posts: 850
Joined: Wed Nov 17, 2004 10:05 pm
Location: Nevada
Contact:

Post by RollerNetSupport » Fri Jul 17, 2009 9:21 am

No, it appears the logging handler died this morning when syslogd restarted after rotating logs. We just now started it back up. Odd, because it's just a copy of the same logging handler reading a FIFO used on the other mail servers.
Technical Support support@rollernet.us
Roller Network LLC

Black20VT
Posts: 134
Joined: Sat Nov 05, 2005 12:35 pm
Location: UK
Contact:

Post by Black20VT » Fri Jul 17, 2009 9:28 am

Ah ha, saves me scratching my head trying to work it out.

Thanks for the update :wink:

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest