help with exim4 config

Need help? Ask here.

Moderator: Moderators

Post Reply
dingetje
Posts: 3
Joined: Wed Sep 27, 2006 1:14 am

help with exim4 config

Post by dingetje » Wed Sep 27, 2006 1:29 am

I'm using your free SMTP redirect service, but rollernet.us keeps on changing my settings to "Defer All" because my mail server is rejecting some messages based on contents (viagra).

2006-08-21 08:26:15 1GF56t-0005gH-67 H=mail.rollernet.us [208.11.75.2] F=<lenora@rizzhart.com> rejected after DATA: This message matches a blacklisted regular expression ([Vv] *[Ii] *[Aa] *[Gg] *[Rr] *[Aa])
also 'Unroutable address' replies are send back to rollernet.us

How can I configure exim4 to never send a reject back to rollernet.us without turning my mail server into an open relay?

RollerNetSupport
Site Admin
Posts: 850
Joined: Wed Nov 17, 2004 10:05 pm
Location: Nevada
Contact:

Post by RollerNetSupport » Thu Sep 28, 2006 7:53 pm

Unknown user errors can be avoided by configuring a valid user table in the account control center; this allows our mail servers to reject messages rather than accepting them as valid when your server will reject them anyway. (This is actually a policy of our service as an effort to mitigate backscatter. Dictionary attacks make it impractical for our service to just act as a blind secondary.)

As far as whitelisting in Exim, I've never used it, so I can't really help there.
Technical Support support@rollernet.us
Roller Network LLC

dingetje
Posts: 3
Joined: Wed Sep 27, 2006 1:14 am

Post by dingetje » Fri Sep 29, 2006 5:51 am

Thanks for your reply :D
I've found your User Table policy page http://forums.rollernet.us/viewtopic.php?t=236 and have now added these in my domain settings, however some messages as in the example above are sent to valid user accounts in my domain.

Your backscatter policy page explains what needs to be done (namely silently ignore instead of generating backscatter)

http://rollernet.us/policy/backscatter.php

I was hoping there are people here that also use exim4 with your service that can give me some pointers as howto accomplish this. The exim4 manual is very extensive and I don't know where to begin. :? :oops:

dingetje
Posts: 3
Joined: Wed Sep 27, 2006 1:14 am

Post by dingetje » Mon Oct 02, 2006 9:16 am

Found it:

By changing the 'deny' command in exim config to a 'discard' command (same syntax) the rejected messages are placed in /dev/null.

My SMTP bounce logs stay clean now :D

Post Reply