Problem receiving e-mail

Need help? Ask here.

Moderator: Moderators

Post Reply
nagetech
Posts: 1
Joined: Fri May 05, 2006 4:58 am

Problem receiving e-mail

Post by nagetech » Fri May 05, 2006 5:04 am

First off, I would like to thank rollernet for all their hard work! Their service has been very reliable!

On to my problem. As of yesterday, I've noticed I am not receiving e-mails. In looking at the logs here at rollernet, I've noticed the following:

Connection from 209.123.8.28 (halo.idns3.com) rejected by mail.rollernet.us

Message: Recipient rejected by final destination (in reply to RCPT TO command)

That is just one example. Why is rollernet blocking all my emails now? Is there a setting I have overlooked/do not know about? I have changed nothing on my mail server.

Thanks in advance for any advice in the right direction.

tvierling
Posts: 14
Joined: Fri May 05, 2006 10:50 am
Contact:

Re: Problem receiving e-mail

Post by tvierling » Fri May 05, 2006 10:53 am

nagetech wrote:First off, I would like to thank rollernet for all their hard work! Their service has been very reliable!

On to my problem. As of yesterday, I've noticed I am not receiving e-mails. In looking at the logs here at rollernet, I've noticed the following:

Connection from 209.123.8.28 (halo.idns3.com) rejected by mail.rollernet.us

Message: Recipient rejected by final destination (in reply to RCPT TO command)
It looks like the Rollernet servers are doing recipient verification. The program doing it is apparently choking on multi-line SMTP greetings such as

220-foo bar baz
220 foo bar baz

So, if you can turn off multi-line SMTP greetings for now, you may want to do so. Hopefully this can be fixed in the recipient verification program now being used by Rollernet. (Hi Admins! <g>)

matrey
Posts: 2
Joined: Fri Feb 10, 2006 12:53 pm
Location: France

Post by matrey » Sat May 06, 2006 9:44 am

up !

I have the same problem. My main MX server is down for the first time since 1 year, and I'm very sad to see that all incoming mails are rejected by rollernet secondary MX... (it's better than no mails at all, because thanks to the logs I can see who tried to send me a mail)

But it's strange, because SMTP greetings on only one line are very unusual...


Hope they will fix it ASAP...

RollerNetSupport
Site Admin
Posts: 850
Joined: Wed Nov 17, 2004 10:05 pm
Location: Nevada
Contact:

Post by RollerNetSupport » Sun May 07, 2006 11:58 am

It's fixed now. Multiline response support was present, but the pattern matching expression was too strict for some cases. I've relaxed the check (and made it recognize 220 or 250 responses for connection and HELO responses, even though the RFC's only specify one or the other) so it should be fine now.
Technical Support support@rollernet.us
Roller Network LLC

Post Reply